[Linux]CentOS 5.3/5.4のsudoコマンドが曲者。

CentOS 5.3以降で、sudoコマンドのバージョンが新しくなり、sudoコマンド自体や、今まで使えていたsudoを含むスクリプトなどが使えなくなってしまうケースが出てきました。私も同様の現象にはまりました。私の場合は、スクリプト内で使用しているsudo付のコマンドでPATHが通らなくなってしまったという現象です。

今は以下のURLなどを参考に解決し、今まで通りの運用をしています。

記憶の片隅にでも覚えておいてもらえると役に立ったりするときがくるかもしれません。

About: uechoco


One thought on “[Linux]CentOS 5.3/5.4のsudoコマンドが曲者。”

  1. 私も同じ問題に(たぶん)にぶつかって、いろいろgoogleっていたら
    ここにたどりつきました。5.4をインストールした直後だったので、
    最初はインストール時の設定が悪いのか?と悩んでしまいました。

    はやく解決法が知りたいです。

Comments are closed.